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Preface 
ModelUI is a MatlabTM App to demonstrate how to use the muitoolbox to create bespoke interfaces for 

data analysis and modelling applications that produce some combination of graphical and/or time 

series outputs. The muitoolbox is designed to enable the rapid prototyping of models by allowing the 

model developer to focus on the model, rather than the functional or operational needs of the software 

package itself.  To this end, the UI provides a standard interface with drop-down menus, tools to open 

and close files, keep track of model runs, provide a rapid means to implement model set-up and data 

import and export, derivation of new variables, and some basic plotting and statistical tools. The 

ModelUI package includes three example models to illustrate how to create and modify the UI for 

different applications. These include: 

VerticalProfile to illustrate the basic UI and a simple model producing spatial data 

SimpleTide to illustrate handling timeseries data in a similar UI. 

Diffusion2D to illustrate how to handle time plus 2 or 3 space dimensions. 

 

Requirements 
The model is written in MatlabTM and provided as Open Source code (issued under a GNU General 

Public License) and runs under v2016b or later. ModelUI uses the muitoolbox and dstoolbox. 

 

Resources 
The ModelUI App and two toolboxes (muitoolbox and dstoolbox) can be downloaded from 

www.coastalsea.uk.  

Cite as: 

Townend, I.H., 2021, ModelUI manual, CoastalSEA, UK, pp26, www.coastalsea.uk. 
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Revision history 

Version Date Changes 

3.0 May 2021 ModelUI packaged as a Matlab App and migrated to use muitoolbox 

and dstoolbox. 

2.1 Dec. 2020 Help text added to function. Various bug fixes. Package core suite as a 

toolbox. 

2.0 July 2019 Restructured UI, Data and Model classes to make Data and Models 

independent of class handles defined for a specific UI. This allows 

Data and Model classes to easily be used in any UI, or for multiple 

models to be included within a single UI. Unfortunately, this means 

that Classes developed for version 1.1 need to be updated (a relatively 

minor task) because they are no longer compatible.  

All imported data sets and model outputs now inherit either TSDataSet 

for timeseries data and DSDataSet for table data. These super classes 

in turn inherit the generic functions in DataSet. This allows data sets 

with different formats to be included in the same class (e.g. imported 

wave data with different variables and formats). 

Added descriptive and timeseries statistics class (DataStats) and range 

of functions (in MUIfunctions) so that Statistical analysis can be 

included in the UI. 

Added panel to tabs in DataGUIinterface to improve behaviour 

Improved behaviour when running multiple UIs/Models 

1.1 June 2018 Minor corrections to improve cross-platform compatibility 

Fixed bugs when setting data ranges in Data GUIs and selecting data 

from a pop-up list. 

Improved plotting option selection for xyz data with no time  

Scenario selection added to control of Plot tab 

1.0 Mar 2018 Full release with some updates to code but no changes to model 

structure or requirements. 

0.1 Jan 2018 Preliminary release via www.coastalsea.uk 
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1 Introduction 
Whether prototyping a new method or writing a new application, dealing with the coding 

infrastructure needed to handle the user interface, data input/output and plotting the results can be time 

consuming. ModelUI aims to speed up the process and provide users with a standard UI that can be 

rapidly adapted for new applications. This manual explains the functionality of the standard UI and 

how it can be used as the UI for other models. There are three sample models to illustrate different 

ways of using ModelUI. Within ModelUI there is a simple model for vertical velocity profiles. The 

SimpleTide model illustrates handling of timeseries data within an interface that uses ModelUI. The 

Diffusion2D model illustrates how to handle how to handle time plus 2 or 3 space dimensions with its 

own bespoke interface. These models are summarised in Section 4.  

The models supplied with ModelUI are used to illustrate how to implement some basic uses of 

ModelUI and the muitoolbox. There are two ways of doing this:  

(i) using the ModelUI interface ‘as is’ and adding a new model to the interface.  

(ii) implementing a bespoke interface to provide the required functionality.  

The requirements and options available are explained in the muitoolbox documentation and manual. 

A simple model may only require the addition of one new class to implement using default ModelUI 

interface. However much more sophisticated applications are also possible. The ASMITA and 

CoastalTools applications use muitoolbox to implement bespoke interfaces to meet the needs of the 

application. They also provide a resource for many data handling methods that may be of use for other 

applications. These include some variations of the default statistical methods, as well as a variety of 

alternative plotting options. 
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2 Getting started 
2.1 Configuration 
ModelUI is installed as an App and requires muitoolbox and dstoolbox to be installed. The download 

for each of these includes the code, documentation and example files. The files required are:  

dstoolbox: dstoolbox.mltbx 

muitoolbox: muitoolbox.mltbx 

The App file: ModelUI.mlappinstall 

2.1.1 Installing the toolboxes 
The two toolboxes can be installed using the Add-Ons>Manage Add-Ons option on the Home tab of 

MatlabTM. Alternatively, right-click the mouse on the ‘mltbx’ files and select install. All the folder 

paths are initialised upon installation and the location of the code is also handled by Matlab™. The 

location of the code can be accessed using the options in the Manage Add-Ons UI. 

2.1.2 Installing the App 
The App is installed using the Install Apps button on the APPS tab in Matlab™. Alternatively, right-

click the mouse on the ‘mlappinstall’ file and select install. Again all the folder paths are initialised 

upon installation and the location of the code is handled by Matlab™. 

Once installed, the App can be run from the APPS tab. This sets the App environment paths, after 

which the App can be run from the Command Window using: 

>> ModelUI; 

The App environment paths can be saved using the Set Path option on the Matlab™ Home tab. 

Documentation can be viewed from App Help menu, or the Supplemental Software in the Matlab™ 

documentation. The location of the code can be accessed by hovering over the App icon and then 

finding the link in the pop-up window. 

2.2 Model Set-up 
File>New to create a new project space. 

Setup>Input Data>Model Data 

The UI requests data for the model variables. Once added the current set of variables can be viewed 

using the Inputs tab. 

Run> Run model 

When the run has completed the user is prompted to provide a description of the model run (scenario).  

The run is listed on the Cases tab and the tidal elevations for the most recent run can be viewed on the 

Plot tab.  

Plot>Plot menu 

The results from a run can be selected and plotted. By using the Add button additional model runs can 

be included on the plot, allowing different Cases to be compared.  
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3 Application Menus 
The UI comprises a series of drop down menus that provide access to a number of commonly used 

functions such as file handling, management of run scenarios, model setup, running and plotting of the 

results. In addition, Tabs are used to display set-up information of the Cases that have been run. In this 

manual text in Red italic refers to drop down menus and text in Green italic refers to Tab titles. 

 

3.1 File 
File>New: clears any existing model (prompting to save if not already saved) and a popup dialog box 

prompts for Project name and Date (default is current date).  

File>Open: existing models are saved as *.mat files. User selects a model from dialog box. 

File>Save: save a file that has already been saved. 

File>Save as: save a file with a new or different name. 

File>Exit: exit the program. The close window button has the same effect. 

 

3.2 Tools 
Tools>Refresh: updates Cases tab. 

Tools>Clear all>Project: deletes the current project, including setup parameters and all Cases. 

Tools>Clear all>Figures: deletes all results plot figures (useful if a large number of plots have been 

produced). 

Tools>Clear all>Cases: deletes all cases listed on the  Cases tab but does not affect the model setup. 

 

3.3 Project 
Project>Project Info: edit the Project name and Date. 

Project>Cases>Edit Description: select a scenario description to edit. 

Project>Cases>Edit Data Set: edit a data set. Initialises a data selection UI to define the record to be 

edited and then lists the variable in a table so that values can be edited. The user can also limit the data 

set retrieved based on the variable range and the independent variable (X) or time. This can be useful 

in making specific edits (eg all values over a threshold or values within a date range). 

Project>Cases>Save: select the Case to be saved from the list of Cases and is prompted to save the 

Case as a dstable or a table and then to name the file. The dataset dstable or table are saved to a mat 

file.  

Project>Cases>Delete: select the Case(s) to be deleted from the list of Cases and these are deleted 

(model setup is not changed). 

Project>Cases>Reload: select a previous model run and reload the input values as the current input 

settings. 

Project>Cases>View settings: display a table of the model input parameters used for a selected model 

run (Case). 

Project> Import/Export>Import: load a Case class instance from a Matlab binary ‘mat’ file. Only 

works for data sets saved using Export.  

Project>Import/Export>Export: save a Case class instance to a Matlab binary ‘mat’ file. 

These last two functions can be used to move Cases between projects or models. 
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NB: to export the data from a Case for use in another application (eg text file, Excel, etc), use the 

Project>Cases>Edit Data Set option to make a selection and then use the ‘Copy to Clipboard’ button 

to paste the selection to the clipboard. 

 

3.4 Setup 
The setup menu provides a series of menus to enable different components of the model to be defined.  

Setup>Import Data: dialog with sub-menu options to Load,  Add, Delete, Quality Control. The 

availability of these options may vary depending on what is defined in the data specific format file. 

Select one or more files to load. Once added the current set of variables can be viewed using the Inputs 

tab. When the data has been loaded, the user is prompted to provide a description of the data set 

(scenario) and is listed on the Cases tab. The source file(s) area also listed on the Inputs tab.   

Setup>Import data> Load data: prompts for file format to be loaded. The options available vary with 

Data type and then loads the data and prompts for a description (working title) for the data set. 

Setup>Import data > Add data: prompts for file to be added (only one file at a time can be added) and 

the Case to use (if more than one Case). Only files with the format used to create the data set can be 

used to Add data to a data record and this is selected when the first file is loaded using the Load menu 

option. 

Setup>Import data > Delete data: prompts for Case from which some part of the data is to be deleted. 

Setup>Import data > Data QC: runs a series of checks on the data. This is only available if defined 

for the specific data format. 

Setup> Input Parameters: enter and edit the specified model parameters. 

Setup>Input Data>Model Constants: various constants are defined for use in models, such as the 

acceleration due to gravity, viscosity and density of sea water, and density of sediment. Generally, the 

default values are appropriate (9.81, 1.36e-6, 1025 , 2650 respectively) but these can be adjusted and 

saved with the project if required. 

 

3.5 Run 
Run> Run Model: runs model, prompts for Case description which is added to the listing on the Cases 

tab.  

Run> Derive Output: data that has been added (either as data or modelled values) can be used to 

derive new variables. The UI allows the user to select data and use a chosen selection of 

data/variable/range to define either a Variable, XYZ dimension, or Time. Each data set is sampled for 

the defined data range. If the data set being 

sampled includes NaNs the default is for these 

to be included (button to right of Var-limits is 

set to ‘+N’). To exclude NaNs press the button 

so that it displays ‘-N’.  

The selection is assigned by clicking one of the 

X, Y or Z buttons. The user is prompted to 

assign a Variable, XYZ dimension, or Time 

(the options available varies with the type of 

variable selected) – see Section 3.9 for details 

of how this works. An equation is then defined 

in the text box below using the x, y, z or t 
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variables1. Based on the user selection the routine applies the defined variable ranges to derive a new 

variable. In addition text inputs required by the call and the model object (mobj) can also be passed. 

Comments can be used to pass additional instructions, such as the inclusion of the RowNames in the 

output to be saved as a new dataset, using either %time or %rows. 

For example, any of the following could be entered into the equation box: 

x.^2+y   %time 

myfunction1(x,y,t,'usertext')  

myfunction2(x,mobj) 

The output from function calls can be figures or tables, a single numeric value, or a dataset to be saved 

(character vector or array). External functions must return output as a cell array with the new variable 

in the first cell and data to be used to define RowNames in the second cell. If the %time or %rows 

instruction is included in the call, row data are added providing that the length of the input dataset 

matches the output dataset. If there is no output to be passed back the function should return a cell 

array containing the string 'no output' to suppress the message box, which is used for single value 

outputs. For expressions that return a result that is the same length as one, or more, of the variables 

used in the call, there is also the option to add the variable to one of the input datasets as a new 

variable. In all there are three ways in which results can be saved: 

1. Expression or function returns a result that is the same number of rows as one or more of the input 

datasets. Option to (a) add as a new variable to an existing data set, or (b) create a new dataset 

with no assignement to the RowNames property. 

2. As (1) with the comment of %time or %rows in the call. Attempts to use the RowNames property 

of one of the inputs to define RowNames in a new dataset. Requires the input variables to have 

same number of rows. (Plan to add interpolation so this may change). 

3. Expression or function returns a result with a new variable and time time in a 2-element cell array. 

The variable is saved as a new dataset. 

An alternative when calling external functions is to pass the selected variables as dstables, thereby also 

passing all the associated metadata and RowNames for each dataset selected. For this option up to 3 

variables can be selected but they are defined in the call using dst, for example: 

myfunction3(dst,'usertext',mobj) 

This passes the selected variables as a struct array of dstables to the function. Using this syntax the 

function can return a dstable, or struct of dstables, or a cell array containing one or more data sets. The 

options for saving the data are the same, with the additional option that when a dstable, or struct of 

dstables, is returned, these are saved directly and it is assumed that the dsproperties have been defined 

in the function called. 

Some further details on using this option and the ‘Function’ library available are provided in Section 

4.4. 

 

3.6 Analysis 
Plotting and Statistical Analysis both use the standard Data selection UI. These both require Case, 

Dataset and Variables to be selected from drop-down lists and assigned to a button. Further details of 

how this works are given in Section 3.9. The sections below present all the options available. 

However, the options enabled vary with each application. This can be changed by editing the 

 

1 Various pre-defined function templates can be accessed using the ‘Function’ button. Alternatively, text can be 

pasted into the equation box from the clipboard by right clicking in the text box with the mouse. 
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DataUItabs property for Plot and Stats in the setMUI function of the model class (e.g. ModelUI, 

SimpleTide or Diffusion2D). 

3.6.1 Plotting 
Analysis>Plot menu: initialises the Plot UI to select variables and produce several types of plot. The 

user selects the Case, Dataset, and Variable to be used and the plot Type from a series of drop-down 

lists. There are then buttons to create a New figure, or Add, or Delete variables from an existing figure 

for 2D plots, or simply a Select button for 3D and 4D plots. The following figures illustrate the options 

available. 

 

2D plot 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign a variable, or a dimension, to the Var and X 

buttons to set the Y and X axes, respectively 

Each selection can be scaled (log, normalised, etc) 

and the range to be plotted can be adjusted when 

assigning the selection to a button. 

> Select plot type (line, bar, scatter, stem, etc) 

Control Buttons: 

→ : updates the list of Cases  

XY :  swaps the X and Y axes 

+ : switches between cartesian and polar plot type 

If polar selected then Ind assumed to be in degrees. 

 

3D plot 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, X and Y buttons 

Take care to ensure that the assignments to X and Y 

correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

 

Control Buttons: see 2D plot above. 

 

 

4D 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, X, Y and Z buttons 

Take care to ensure that the assignments to X, Y and 

Z correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

To produce a new plot, use the Clear button to remove 

the previous selection.   

 

Control Buttons: see 2D plot above. 
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For all plot types, when the data has more dimensions than the plot or animation the user is prompted 

to sub-select from the data (by selecting sampling values for the dimensions that are not being used). 

Animations follow a similar workflow. There are buttons at the bottom of each tab to:  

Run the selection and create an animation,  

Save the animation to a file (the animation needs to have been run first) . There is also an option to 

save on the bottom left of the animation figure. 

Clear the current selection. 

 

 

2DT animation 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign a variable, or a dimension, to the Var, Time 

and X buttons. 

Each selection can be scaled (log, normalised, etc) and 

the range to be plotted can be adjusted when assigning 

the selection to a button. 

> Select plot type (line, bar, scatter, stem, etc) 

Control Buttons: 

→ : updates the list of Cases  

+ : switches between cartesian and polar plot type 

If polar selected, then X assumed to be in degrees and 

when prompted select Polar and NOT Rose. 

 

3DT animation 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, Time, X and Y buttons 

Take care to ensure that the assignments to Time, X 

and Y correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

 

Control Buttons: see 2DT plot above. 

 

 

4DT animation 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, Time, X, Y and Z 

buttons 

Take care to ensure that the assignments to Time, X, Y 

and Z correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

 

Control Buttons: see 2DT plot above. 
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Selection of User plot type 

Calls the user_plot.m function, where the user can define a workflow, accessing data and functions 

already provided by the particular App or the muitoolbox. The sample code can be found in the 

psfunctions folder  and illustrates the workflow to a simple line plot using x-y data from the 2D tab 

and a surface plot using x-y-z data from the 3D tab. 

 

3.6.2 Statistics 
Analysis> Statistics: several statistical analysis options have been included within the Statistical 

Analysis GUI. The tabs are for General statistics, Timeseries statistics, model comparisons using a 

Taylor Plot, and the generation of a new record based on the statistics over the Intervals defined by 

another timeseries. 

General tab 
The General tab allows the user to apply the following statistics to data loaded in ModelUI:  

1) Descriptive for X: general statistics of a variable (mean, standard deviation, minimum, maximum, 

sum and linear regression fit parameters). Only X 

needs to be defined. The range of the variable can be 

adjusted when it is assigned to the X button (see 

Section 3.9). If the variable being used is a multi-

dimensional matrix (>2D), the user is prompted to 

define the range or each additional dimension, or 

select a value at which to sample. The function can 

return statistics for a vector or a 2D array. 

 

The results are tabulated on the Stats>General tab and 

can be copied to the clipboard for use in other 

applications. 

 

2) Regression: generates a regresion plot of the dependent variable, Y, 

against the independed variable, X. For time series data, the default data 

range is the maximum period of overlap of the two records. For other data 

types the two variables must have the same number of data points. After 

pressing the Select button, the user is prompted to select the type of model 

to be used for the regression. The results are output as a plot with details of 

the regression fit in the plot title. 

 

 

 

3) Cross-correlation: generates a cross-corrleation plot of 

the reference variable, X, and the lagged variable, X (uses 

the Matlab ‘xcorr’ function). For time series data, the 

default data range is the maximum period of overlap of 

the two records. For other data types the two variables 

must have the same number of data points. This produces 

a plot of the cross-correlation as a function of the lag in 

units selected by the user. 

 



 
ModelUI manual 

May 2021 

 

 

12 

 

4) User: calls the function user_stats.m, in which the user can implement their own analysis methods 

and display results in the UI or add output to the project Catalogue. Currently implements an 

analysis of clusters as detailed for Timeseries data below. 

 

3.7 Help 
The help menu initialises the App documentation in the MatlabTM Supplemental Software 

documentation. 

 

3.8 Tabs 
To examine what has been set-up the Tabs provide a summary of what is currently defined. Note: the 

tabs update when clicked on using a mouse but values displayed cannot be edited from the Tabs. 

Cases: lists the cases that have been run with a case id and description. Clicking on the first column of 

a row generates a table figure with details of the variables for the case and any associated metadata. 

Buttons on the figure provide access the class definition metadata and any source information (files 

input or models used).  

Inputs: tabulates the system properties that have been set (display only). 

Q-Plot: displays a quick-plot defined for the class of the selected case (display only). 

Stats: displays a table of results for any analyses that have been run (can be copied to clip board). 

 

3.9 UI Data Selection 
Functions such as Derive Output (3.5), Plotting (3.6.1) and Statistics (3.6.2) use a standardised UI for 

data selection. The Case, Dataset and Variable inputs allow a specific dataset to be selected from drop 

down lists. One each of these has been set to the desired selection the choice is assigned to a button. 

The button varies with application and may be X, Y, Z, or Dependent and Independent, or Reference 

and Sample, etc. Assigning to the button enables further sub-sampling to be defined if required. Where 

an application requires a specific number of dimensions (eg a 2D plot), then selections that are not 

already vectors will need to be subsampled. At the same time, the range of a selected variable can be 

adjusted so that a contiguous window within the full record can be extracted. In most applications, any 

scaling that can be applied to the variable (e.g. linear, log, relative, scaled, normalised) is also selected 

on this UI. The selection is defined in two steps: 

 

Step 1.  

Select the attribute to use. This can be the variable 

or any of its associated dimensions, which are 

listed in the drop-down list. 

The range for the selection can be adjusted by 

editing the text box or using the Edit (Ed) button. 

Any scaling to be applied is selected from the 

drop-down list. 

Press Select to go to the next step or Close to quit. 

 

The number of variables listed on the UI depends on the dimensions of the selected variable. For each 

one Select the attribute to use and the range to be applied.  
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Step 2 - Variable only has 

dimension of time. 

 

No selection to be made. 

Edit range if required. 

 

 

 

Step 2 - Variable has 3 dimensions but only 

2 are needed for the intended use. 

 

Select the 1st variable  to use as a dimension 

Edit range if required. 

 

Select the 2nd variable  to use as a dimension 

Edit range if required. 

Use the slider or the Edit (Ed) button to set 

the value of the dimension to use. (A value of 

t=500 is selected in the example shown). 

Press Select to accept the selection made. 

[NB: Only unused dimensions can be selected from the Select drop-down lists. To adjust from the 

default list this can sometimes require that the second Select list-box is set first to allow the first Select 

list-box to be set to the desired value.] 

The resulting selection is then detailed in full (including the ranges or values to be applied to all 

dimensions) in the text box alongside the button being defined. 

Note where a variable is being selected as one property and a dimension as a second property, any 

sub-selection of range must be consistent in the two selections. This is done to allow variables and 

dimensions to be used as flexibly as possible.  
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4 Demonstration models 
To illustrate the use of the interface for different types of output (graphical and time series), four 

sample models are provided. The first model is provided as the demonstrator model within ModelUI 

and computes the vertical tidal current profile.  The second model generates a simple tidal curve, and 

the third generates an animation of 2D diffusion. These models also illustrate the following types of 

change to the core functionality of ModelUI: 

SimpleTide –  emulates tidal elevation and velocity as timeseries over a specified period. 

Diffusion2D – The main purpose of this model is to illustrate the use of tables to hold a multi-

dimensional array that defines a variable at each time-step (eg 1, 2 or 3D arrays to represent a variable 

in x, y and z). 

The models themselves are briefly summarised in the following sections. How to modify ModelUI, or 

develop a new application, is explained in the muitoolbox manual. 

 

4.1 Vertical Tidal Current Profile 
The model used in the ModelUI App implements the approach outlined by Prandle (1982) to compute 

the variation of the vertical profile given measurements at one elevation. This implementation has the 

option to use several different eddy viscosity formulations when computing the profile. 

4.1.1 Workflow to Run Model 
The following outlines the steps in a typical workflow to setup and run the vertical tidal current profile 

mode.: 

File>New – create a new project (name and date)  

Setup>Input Data>Model Data – define model parameters (see 

Prandle (1998) for details of the parameters required. To see the 

parameters that are currently set for the model use the Inputs 

tab. 

File>Save as – save model setup to a *.mat file. 

Run>Run model – runs the model and prompts user for a 

description of the scenario. The results can be viewed on the 

Q-Plot tab. 

Completed ‘Cases’ are listed based on the user descriptions on 

the Cases tab. 

 

4.1.2 Plotting results 
Results can be plotted using the plotting UI (Plot>Plot Menu). 

Eddy viscosity cases can be selected individually and plotted 

against profiles from other Cases. 
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Figure 1 – Vertical profiles from a model run plotted in UI Plot tab and comparing several Cases using the Plot Menu 

 

4.2 Simple tide 
SimpleTide provides a simple representation of the diurnal-semidiurnal and spring-neap variations in 

the tide based on simple summation of M2, S2 and O1 contributions, scaled to the defined tidal range. 

Tidal currents are derived in a similar way and scaled to the defined tidal velocity amplitude. The 

model generates a time series of tidal amplitude, vertical and horizontal velocity based on defined 

amplitude and phases. The model is implemented in two ways, to illustrate different ways of adding 

models 

(i) By defining a new class, STData for data input and a model function file simpletidemodel. 

This runs within ModelUI and is similar to the implementation of the Vertical Profile model. 

(ii) by defining three new classes: SimpleTide, STData and STModel. The SimpleTide class 

inherits from ModelUI and redirects menu options to STData and STModel. This illustrates a 

minimal adjustment to add a new model. The STData and STModel classes simply define a 

bespoke data input and replace Model in ModelUI. 

 

4.3 Diffusion model 
Diffusion2D implements the 2-D Diffusion equation using a Finite Difference Method. The Numerical 

scheme used is first order upwind in time and second order central difference in space, with Implicit 

and Explicit options and either Dirichlet or Neumann boundary conditions. The model operates on a 

rectangular domain and is perturbed over a defined area at t=0 and then allowed to diffuse at a rate 

determined by the diffusion coefficient. This application implements the solution of the 2-D diffusion 

equation based on the code developed by Suraj Shanka, Copyright (c) 2012 and made available via the 

Matlab TM Exchange Forum. The main purpose of this application is to provide time varying 2-D data 

(and 3-D by replicating the 2-D matrix) to demonstrate the use of variables that have dimension of 

time and xyz. A dstable can hold multiple variables for each time step, each with a consistent xyz 

definition (i.e. the size of the variable array at each time step is constant). The positions that define 

XYZ and Time are stored as properties of the dstable and each (multi-dimensional) variable is a 

column vector in the table. If the variable array remains constant but the positions (xyz) change with 

time, then xyz need to be added as variables rather than as an xyz definition. The model is 

implemented by defining four new classes: Diffusion2D, DFmodel, DFparams and DFrundata. In 

addition, the function difffusion2Dmodel does the diffusion computations. DFparams and DFrundata 

classes are for data entry, illustrating how to separate out different aspects of the model input 
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information. The Diffusion2D class inherits ModelUI to provide model specific functionality and the 

DFmodel class implements the control of model runs, tab plot display and holds the model results. 

4.3.1 Functions to derive additional outputs 
The function userderivedoutput can be called using the Derive Output UI, to generate either the 

integral under the surface at each time step, or the surface gradients at each time step.  

For the integral option enter > userderivedoutput(t,x,y,z,’integral’) 

For the gradient option enter > userderivedoutput(t,x,y,z,’gradient’) 

 

  

 

4.4 Derive Output 
The Run> Derive Output option allows the user to make use of the data held within ModelUI to derive 

other outputs or, pass selected data to an external function (see Section 3.5). The equation box can 

accept t, x, y, z in upper or lower case. Time can be assigned to X, Y, or Z buttons or simply included 

in the equation as t (as long as the data being used in other variables includes a time dimension). Each 

data set is sampled for the defined data range. If the data set being sampled includes NaNs, the default 

is for these to be included (button to right of Var-limits is set to ‘+N’). To exclude NaNs press the 

button so that it displays ‘-N’. The selection is assigned to the variable limits whenever the current 

variable is assigned to X, Y or Z using the X, Y, Z buttons. 

The equation string entered in the GUI is used to construct an anonymous function as follows: 

heq = str2func(['@(t,x,y,z,utext,mobj) ',usereqn]); %handle to anonymous 

function 

var = heq(t,x,y,z,utext,mobj);   
 

This function is then evaluated with the defined variables for t, x, y, and z and optionally utext and 

mobj. utext allows text string to be passed (any string enclosed in single quotes, e.g. ‘Test’) and mobj 

passes the ModelUI handle. 

Some functions may alter the length of the reference co-ordinates (x, y, z, t), or return more than one 

variable. These can be handled by passing a comment appended to the function definition e.g. 

subsample(x,t, thr,mobj) %time. In this version only ‘time’ is handled as a key word and this allows 

functions to derive a new timeseries with different time input values to those of the input variable(s). 

If the function returns a single valued answer, this is displayed in a message box, otherwise it is saved, 

either by adding to an existing dataset, or creating a new one. There are three options: 

1. Create a New Definition. The data type is ‘derived’, using the Derived class which is assigned to 

the h_Derived class handle and the user defines the metadata specific to the instance (i.e. ResDef).  
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2. Create a New Case. This uses an existing Derived class instance and adds a new record to the 

selected instance using the existing Derived class instance variable definitions (i.e. ResDef). 

3. Add to an Existing Case. This adds the variable to an existing Case by adding a new variable to 

the tscollection or table. The new variable definition is used to extend the existing Derived class 

instance variable definitions (i.e. ResDef).  

Details of the implementation of these options is given in Section 3.5. 

For vector data of the same length any range limits defined are applied to all the variables used and the 

result variable dimensions are also adjusted. Where one or more variables is an array, range limits are 

applied as follows: 

(i) Limits for the variable itself are applied by replacing values with NaNs; 

(ii) Limits to the first dimension (time or x) are applied by removing rows that are outside the limits; 

(iii) The dimensions of the array in each row are adjusted based on any limits set for the array 

dimensions. 

Note: Limits are only set for dimensions that are included as variables in the equation. 

Equations can use functions such as diff(x) - difference between adjacent values - but the result is n-1 

in length and may need to be padded, if it is to be added to an existing derived data set. This can be 

done by adding a NaN at the beginning or the end: e.g.: [NaN;diff(x)]. NB: the separator needs to be a 

semi-colon to ensure the correct vector concatenation. Putting the NaN before the equation means that 

the difference over the first interval is assigned to a record at the end of the interval. If the NaN is put 

after the function, then the assignment would be to the records at the start of each interval.  

NB1: If the function returns multiple outputs only the first is used. 

NB2: functions are forced to lower case (to be consistent with all Matlab functions), so any external 

user defined function call must be named in lower case. 

Another useful built in function allows arrays to be sub-sampled. This requires the array, z to be 

multiplied by an array of the same size. By including the dimensions in a unitary matrix, the range of 

each variable can be defined. For a 2D array that varies in time one way of doing this is: 

>> z.*repmat(1, length(t), length(x), length(y)) 

NB3: the order of the dimensions t, x, y must match the dimensions of the array, z. 

 

This interface can also be used as an interface to user functions that are available in the Matlab search 

path. Simply type the function call with the appropriate variable assignment and the new variable is 

created. (NB: the UI adopts the Matlab convention that all functions are lower case). This is illustrated 

in the Diffusion2D model. The function userderivedoutput can be called with just a single variable 

defined as one of the results from the model to generate either the integral under the surface at each 

time step, or the surface gradients at each time step (see figure in Section 3.5 for inputs used).  

For the integral option enter > userderivedoutput(t,x,y,z,’integral’) 

For the gradient option enter > userderivedoutput(t,x,y,z,’gradient’) 
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Some useful examples primarily for timeseries data include:  

1. Moving Average. There are several moving average functions available from the Matlab 

Exchange Forum, such as moving.m. The call to this function is:  < moving(X, n) >  where n 

specifies the number of points to average over.  

2. Down-sampling a time series. This allows a timeseries to be resampled at a different interval (that 

must be less than the source timeseries). The call to this function is: 

 <downsample(x, t, ’period’, ’method’)>, where x is the variable to be resampled, time is the 

associated time for that variable, period can be ‘year’, ’month’, ’day’, 'hour', 'minute', ‘second’, 

and method can be any valid function call such as ‘mean’, ‘std’, etc. The ‘period’ is required but 

the ‘method is optional and if omitted the mean is used.  

For timeseries with gaps the ‘nanmean’ function is particularly useful but requires the Statistics 

toolbox. 

3. Interpolate and add noise.  To infill a record with additional points and, if required, add some 

random noise to the interpolated values. This is called using: 

<interpwithnoise(x, t, npad, scale, method, ispos)  %time>, where X is the variable, t is time, npad 

is the number of points to add between the existing data points, scale determines the magnitude of 

the random noise (a value of 0 results in an interpolated record with no noise), method is the 

Matlab algorithm used for the interpolation (the default is linear) and ispos is a true/false flag 

which sets negative values to zero if true. 

4. Subsample one record based on a threshold defined for another record (e.g. subsample waves 

based on a threshold water level). Function is: <subsample(X, t,  thr, mobj) %time>, where X and 

t are the variable to be subsampled, thr is the threshold value and mobj is the UI handle (must be 

mobj). The user is prompted to select the dataset and variable to be used to define the condition 

and a condition operator (<=, ==, etc). A time series is returned and added as a Derived data set. 

The user is prompted to define the metadata for the new data set. 

5. Recursive plot. Generates a plot of a variable plotted against itself with an offset (e.g. x(i) versus 

x(i+1) ). This is called from the Derive Output GUI using: <recursive_plot(x, ’varname’, nint)>, 

where x is the variable, ‘varname’ is a text string in single quotes and nint is an integer value that 

defines the size of the offset.  

6. Phase plot. This function is similar to the recursive plot function but generates a plot based on two 

variables that can, optionally, be functions of time. The call to this function is: 

<phaseplot(X, Y , t)> where X and Y are the variables assigned to the respective buttons and t is 
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time (this does not need to be assigned to a button and  t can be omitted if a time stamp for the 

datapoints is not required). 

The Function button on the Derive Output UI provides access to these predefined functions and allows 

the user to select one and load a function call template into the UI equation text box. The list is defined 

in the function functionlibrarylist.m which is in the MUIfunctions folder.  
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5 Program Structure 
The overall structure of the code is illustrated schematically in Figure 2. This is implemented through 

several classes that handle the graphical user interface and program workflows (Main UI) and several 

classes that handle the data manipulation and plotting (Input UIs and Data UIs).  

Figure 2 - – High level schematic of program structure 

 

The interfaces and default functionality are implemented in the ModelUI App using the following 

muitoolbox classes depicted in Figure 3, which shows a more detailed schematic of the program 

structure. See the muitoolbox and dstoolbox documentation for more details. 

Figure 3 – schematic of program structure showing how the main classes from muittoolbox and dstoolbox are used 

 

In addition, the ModelUI App uses the following classes and functions: 

VPparam - handles the input of parameters required by the model. 

VPdata – allows data to be imported for comparison with the model results. 

VPdata_ff – is an alternative to VPdata (edit call in ModelUI to use this option). The class inherits 

muiDataSet but uses the same format file (VPfomrat.m). 

VPmodel – defines model output properties and implements model functions 
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VPformat is used by VPdata and defines the read format and metadata for data being imported. 

 

The SimpleTide example application uses the following classes and functions: 

SimpleTide - inherits from ModelUI and redirects menu options to STData and STModel 

STparam - handles the input of parameters required by the model. 

STdata – allows data to be imported for comparison with the model results. 

STmodel – defines model output properties and implements model functions. 

STformat is used by STdata and defines the read format and metadata for data being imported. 

simple_tide is used to compute the variation of tidal elevation and velocity for given constituents. 

 

The Diffusion2D example application uses the following classes and functions: 

Diffusion2D – inherits from muiModelUI and defines additional options in the user interface. 

DFparams - handles the input of parameters required by the model. 

DFrunprops – handles the run time properties. 

DFmodel – defines model output properties and implements model functions. 

diffusion2Dmodel is a function modified from the code of Suraj Shanka, Copyright (c) 2012, 

downloaded from the MatlabTM Exchange Forum. 

The function userderivedoutput can be called from the Derive Output menu option. Select the x, y and 

z variables of the diffusion dataset as X, Y, Z. The call the function 

userderivedoutput(t,x,y,z,<option>), where <option> is either ‘integral’ or ‘gradient’. The user is then 

prompted to name the new data set and define the display variable (ResDef). The new data set is saved 

as ModelData in the Derived class. 
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